Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

luciano2397

[HELP] How do i update switch firmware having sx os installed? Is there any way i can play online?

12 posts in this topic

Hi Darkumbra,

So i'm here again, asking for your help and hoping you can answer my questions. I just wanted to know if there's a way to update the nintendo switch firmware having sx os installed. You see, i'm currently on 5.1, i never updated since i installed sx os, but now i want to update, i just want my switch on the last version... I think it's important to have everything up to day. If i can do it, how do i do it without getting my switch bricked? And the other thing i wanted to know if there's any possibilities of playing online games with sx os, maybe with another sx os users? or with official Nintendo servers, I remember when i had my Nintendo Wii hacked, I could actually play online having it hacked, the only thing i had to take care about was cheats, I was told not to use cheats. It's similar with Nintendo Switch? If i can play online, how do i do it? 

Thank you all, have a nice day!

Share this post


Link to post
Share on other sites
On 11/26/2018 at 10:23 PM, Tristan3579 said:

Hey bud, you have a good question. Yes there is a way to update your Nintendo Switch firmware version. Though I highly recommend not to and stay where you are. But if you still decide to update, I recommend getting ChoiDujourNX that homebrew application will allow you to update safely without burning the switch fuses, if you burn too many switch fuses your switch will never boot.

If your wanting to update because your wanting to be able to play the latest games that require the latest firmware, there are ways to bypass updates. Try getting the latest Tinfoil app and install the nsp files on there, it will ask to bypass the update notification. Hope this helped!

 

I had a question on this. 

My Switch is on 5.1.0, My SX OS is on 2.6.1

When I try to load certain NSP files, I get an error saying "Title requires higher system firmware".

Do I need to find other NSP's that work with my firmware on 5.1.0? do I need to setup EmuNand and upgrade that to the latest?

Share this post


Link to post
Share on other sites
3 minutes ago, Triumph said:

I had a question on this. 

My Switch is on 5.1.0, My SX OS is on 2.6.1

When I try to load certain NSP files, I get an error saying "Title requires higher system firmware".

Do I need to find other NSP's that work with my firmware on 5.1.0? do I need to setup EmuNand and upgrade that to the latest?

Install your NSP files through Tinfoil, its a homebrew application that installs NSP and bypasses the update popup. Tinfoil will run on sx os.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, Tristan3579 said:

Install your NSP files through Tinfoil, its a homebrew application that installs NSP and bypasses the update popup. Tinfoil will run on sx os.

Thanks for the reply, I'm actually getting that error in Tinfoil (1.52). 

Do i have to allow install of unsigned code, maybe?

Share this post


Link to post
Share on other sites
1 minute ago, Triumph said:

Thanks for the reply, I'm actually getting that error in Tinfoil (1.52). 

Do i have to allow install of unsigned code, maybe?

That I'm unsure about. Depends what version Tinfoil you have and the Switch firmware. Maybe this site can help: 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, Tristan3579 said:

That I'm unsure about. Depends what version Tinfoil you have and the Switch firmware. Maybe this site can help: 

 

ok, thanks again for your help.

Share this post


Link to post
Share on other sites

i know its risky but what I did was,  I make sure my online acct is not logged in - quickly update the OS then go back to airplane mode as soon update is done, my switch is running in 7 point something now, luckily no issues so far

i know its risky but what I did was,  I make sure my online acct is not logged in - quickly update the OS then go back to airplane mode as soon update is done, my switch is running in 7 point something now, luckily no issues so far

 

by the way - I just learned from the comment that you can install nsp using tinfoil to avoid update pop-ups, GOD if only I KNOW I WOULDN'T UPDATE MINE, but then again I got no issues so far, this is the 2nd time I updated my OS, first was when OS is in 6

Share this post


Link to post
Share on other sites

Everyone should be on at least 6.2 firmware. Why is this in the Tutorial section though? This is Help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×