Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

Link420

Guacamelee! 2 [NSP+UPD v65536]

27 posts in this topic

2 minutes ago, ErrADDict said:

OMG Been waiting all day for this one, THANK YOU SO MUCH!

Cheers:peace:

  • Like 2

Share this post


Link to post
Share on other sites
4 minutes ago, ErrADDict said:

Uh oh, just finished installing it using tinfoil and it's not launching :(

Did you install the update too?

Share this post


Link to post
Share on other sites
Just now, ErrADDict said:

The update is what makes it crash it seems, re-installed without the update and it's running fine :)

You can use NSC Builder to patch the update for 6.1.

Share this post


Link to post
Share on other sites
2 minutes ago, ErrADDict said:

What if I'm on 6.2?

Not sure. It was tested on 6.1. Try several method it should work on 6.2 as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×